installing windows 98 on an SSD?

ok i have an SSD plugged into SATA port in an old PC the DVD-ROM(IDE) works fine in DOS as soon as i boot into windows the rom won't read no matter what. i have been at this for a week

i loaded windows XP on another spear HDD for a duel boot setup and the DVD-ROM reads in XP and not windows 98

it also tells me there is a conflict with the IDE drivers in the Device manager

how do i fix this?

i believe if i was installing on a IDE drive i would have no trouble, is it possible for anyone to link me to drivers to kick start the IDE controller?

the DVD-ROM is TS-H552D i have tried to install the drivers but it won't detect the DVD-ROM without the IDE controller...

Update:

the motherboard is D7219P MOTHERBOARD

7 Answers

Relevance
  • ?
    Lv 7
    2 months ago

    Make sure the BIOS, is compatible.

  • 2 months ago

    Use virtualbox. Problem solved.

  • 2 months ago

    Think before you go ahead as even after installing it No modern software supports Windows 98 anymore, but with a few kernel tweaks, OldTech81 was able to get older versions of OpenOffice and Mozilla Thunderbird designed for XP running on Windows 98. ... Even though Windows 98 works fine locally, it doesn't know how to operate on the modern web.

  • 2 months ago

    You need to enable BIOS level IDE (or ATAPI) emulation for the SATA ports, so the BIOS shows them as if they are IDE and the generic windows driver can see them.

    It cannot function with actual SATA-connected drives.

    Another option is to use such as "Bootit bare metal" which will provide an IDE adaption. I've had Dos 6.22 and Windows 3.11 running on a pure SATA system using that.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • Anonymous
    2 months ago

    If Windows XP is reporting a conflict, then that is probably the source of your problem. Since this appears to be an old OEM motherboard, there isn't a proper manual for it, and I can't look up what options it may have in the BIOS. Some things you may want to try are:

    - Moving the drive cable to a different controller (primary vs secondary IDE)

    - Disabling one of the IDE channels 

    - Disabling both IDE channels and using a SATA CD/DVD drive. You will, of course, need to enable emulation mode for SATA

    - Copying the contents of the Windows 98 CD to a partition on the hard drive. You would then just need to boot from a DOS floppy, switch to drive C:, and run Setup.

  • Dick
    Lv 7
    2 months ago

    Most likely your Bios is not capable of supporting it.  Windows backward compatibility doesn't go on forever folks!

  • Anonymous
    2 months ago

    I believe the problem lies in drivers. There are no Win 98 drivers for the hardware you are using.  

Still have questions? Get answers by asking now.