Anonymous
Anonymous asked in Computers & InternetSoftware · 1 month ago

Computer says "Reboot or select proper boot device" after attempting to dual boot Ubuntu.?

So I attempted to install Linux Ubuntu alongside Windows 10. I created partitions on my hard drive and installed Ubuntu from a bootable USB stick. At the end of the installation, just before it said "Installation complete, restart to finish", it said:

"Unable to install GRUB in /dev/sdaExecuting `grub-install /dev/sda` failed.This is a fatal error."After restarting I was met with a screen that says "remove boot device and press enter" (or something like that), which was expected. However having doing this, the screen just says "Reboot or select proper boot device" and I am unable to boot neither Windows nor Ubuntu.

After doing some research it seemed as though the problem is mainly to do with GRUB not installing.

I attempted to manually install grub from the Ubuntu live USB using this:

https://askubuntu.com/questions/831216/how-can-i-r...

However, the terminal displayed the error 'grub-install error failed to register the efi boot entry operation not permitted '.

I am able to access my windows files from the Ubuntu live USB, so it doesn't appear to be the case that the hard drive has been totally wiped or anything, which is good.

I have also tried changing the settings in the BIOS however, this hasn't worked.

Any help or advice would be greatly appreciated, thank you in advance.

Update:

My motherboard is a Gigabyte motherboard.

Update 2:

Gigabyte 990FXA-UD3

Update 3:

I do not have a Win10 recovery installation media, and from what I understand I can't just create one from a different computer, and since I can't boot windows, that is certainly a problem.

Update 4:

@Robert J

I changed the settings in my BIOS settings to 'boot UEFI only' and then attempted to install GRUB from the live USB stick, and it didn't work either. Is this what is meant by the system being in EFI mode? If not How do I do that.?

Update 5:

Given that my live USB has the folder 'sys/firmware/efi', I think it is in EFI mode, however the same error occurs when I try to install GRUB.

5 Answers

Relevance
  • 1 month ago

    Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key.

  • 1 month ago

    See the article here; the system must be in EFI mode for grub to properly install:

    https://superuser.com/questions/376470/how-to-rein...

  • Adrian
    Lv 7
    1 month ago

    It might also have something to do with "secure boot" in your BIOS settings. Or, something else was corrupt in your boot partition (UEFI boot). Hard to diagnose without much more detail about your system/hardware.

    Start off by recovering your Windows boot with a Win10 recovery (install) media. Then try again.

  • Anonymous
    1 month ago

    @keerok

    Thanks for your answer.

    I've tried to install GRUB from the live USB and the terminal returns an error.

    When you say "go to the command line and boot your newly installed ubuntu", do you mean like boot the Ubuntu installed on my hard drive from my live USB? Is there a command I can use from the terminal to do this in the live USB?

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • keerok
    Lv 7
    1 month ago

    Can't remember exactly how and you will have to research the exact commands to do this but I've done it a lot of times years ago when I was setting up a Linux computer lab at a school. 

    Since the Live USB boots, why not use it to install grub? Boot it then instead of proceeding to install, go to the command line and try to boot your newly installed Ubuntu. If that works, reboot then go to GRUB's command line again and reinstall GRUB from there.

Still have questions? Get answers by asking now.