I NEED A GENIUS. Troubleshooting Craftsman 200.57933 Garage Door Openner.?

My Craftsman 200.57933 would sometimes open by itself, sometimes the remote would work and other times it wouldn't.  Even after unplugging it  would sometimes work but not others. Incredibly erratic.  The infrared sensors were fine.  The light would flash several times.  I looked it up and everything pointed to the logic card.  I replaced the logic card and when I plugged it in it opened a little bit, without me pressing anything, then closed again along with 5 blinking lights.  Curiously when I unplugged it and re connected it the light flashes but no movement.  When I looked at the sensors in one lights are completely off the receiving one has a green light flashing.  I checked the connections but they are fine.  Also I checked the wall switch and it shows a steady light however it wold not open when pressed.  I pressed it for 2 seconds and nothing happened.  Now I have questions:

1.  Is there anyway that I can by pass the sensors and wall switch to see if they were the problem.  If I disconnect them from the unit will that bypass it or will the unit simply not work?

2.  I read somewhere that when the light flashes 5 times it's the RPM sensor.  Is that the case for my model?  Info on my model it's scarce apparenty it has been discontinued and it wast very popular.

3.  We were suffering from power outages at the time.  Would that damage all, the logic board, the RPM sensor and the sending sensor?

If you were brave enough to tackle this question I honestly want to thank you!!

5 Answers

Relevance
  • Edwena
    Lv 7
    4 weeks ago

    Over the years we have had a half dozen Sears openers.  If there is a problem, it was in the switch mechanism that makes the electrical contacts.  Everything from being loose to a mud dabber nest.  So look for mechanical problems, not electrical.

  • 4 weeks ago

    search internet for your specific model number and the word 'repair'.  also, get copy [its on the internet] of owner's manual and read the trouble shooting part.  My sister in law had similar problem and I finally traced it down to one of the safety sensors being misaligned [not directly pointed at the other one].  However, I forget her brand and model number [and she lives 40 minutes away, so I'm not going to go look.  that detail?  she's useless on such things -- it involves climbing step ladder to read the number plate on the unit and she won't go higher than second step -- fear of falling.]

  • 4 weeks ago

    It looks like the logic board was not defective after all. I would put it back in and not use the new one. You don't want to get too far away from the original setup, just in case you start changing the original environment, like the new board is not the exact one required for your door (or who knows what).

    The problem could be as simple as the sun shining in on the infrared sensor and blinding it. The sun could be shining directly into the sensor or else the sun could be overhead and shining on the floor in front of the sensor and blinding it. That would account for the erratic behavior and the remote not working.

    Of course the easiest way to test this is to see if the door works at night when there is no sun around. 

  • 4 weeks ago

    I found the user manual for it - download link at the top of this page:

    https://usermanual.wiki/Craftsman/20057933.1618204...

    Does it have a separate board for the remote control receiver? If so it could be that causing problems.

    Or it could be something in the area transmitting on the same or a nearby frequency and "jamming" the remote receiver; that fits with the flashing rx light and occasional random operation.

    If yours has the mechanism I think it does, the limits and load sensor are purely mechanical? 

    The motor body can rotate slightly, held centred by a spring, and if the door hits something or jams the motor body turns with the load reaction and operates a switch. 

    In that case it probably does not have an RPM sensor; that's a part on the newer type with a servo motor rather than the fixed-speed AC motor.

    Examine the mechanism and verify all the switches are working properly and the motor body springs back to centre, if it does have that mechanism.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • Anonymous
    4 weeks ago

    Check power at the outlet.  You should read full house voltage on the multimeter.  This is where you should start.  Check your remote.  Make sure it has the correct battery..  If the battery is correct, check the battery voltage with a multimeter.

    Start your troubleshooting with the sensors.  Make sure they are aligned.  Cover the lens on the transmitting sensor and try closing the door.  You should have a flashing light.  Hold down the switch in the wall control and if the garage door closes, you have a sensor problem.  Sensor should have a steady LED light if it is good and the light should flash in the receiving sensor when you cover the lens with your hand.    If there is no steady light, check the wiring all the way back to the logic card   A continuity test with a multimeter is a must. 

Still have questions? Get answers by asking now.