144hz monitor not showing 144hz?

PC Specs: AMD FX-8350 - GTX 660(2gb) - 8gb RAM

Monitor: ASUS VG248QE 144hz - HDMI connection

My monitor is not performing at its listed refresh rate, but instead says 60hz. Is the issue the outdated graphics card, different connection, or something else?

5 Answers

Relevance
  • 1 month ago

    Right click your wallpaper and click display settings. Then scroll down to where it says display adapter properties.  Then select the monitor tab at the top and then you will see monitor settings and an option that says screen refresh rate and you will be able to select the output of what is available

  • 1 month ago

    Memelord Prime's answer explains it. You'd have to look at the specs and user manual of the monitor to figure out which port and cable you'll need in order to select 144hz in NCP. Typically you'd have top cross-reference the specs to see if the Video Card can also support the correct cables, but the GTX 660 supports DP 1.2, and DL-DVI.

    The FX-8350 and GTX 660 should be able to run older games and somewhat old games at very high framerates, but it will struggle to get newer games at 60fps. It depends on what you play.

  • 2 months ago

    open nvidia control panel and set desired refresh rate

  • Lv 7
    2 months ago

    a monitor can only display what it is given. 144 is just the max. unless your computer's video settings are set to output 144, it probably with stick to the standard 60 hz.

    it may only gove you 144 options on specific games.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 2 months ago

    It's both to an extent.

    The monitor only supports 144Hz over DisplayPort or Dual Link DVI. HDMI on that monitor only goes up to 60Hz.

Still have questions? Get answers by asking now.