RX8 looses power above 6k rpms?

my rx8 looses power above 6k rpm in 3rd 4th and 5th gear had a CEL said Left bank was lean had that corrected any ideas Its a 2009 6 speed with 90k miles other than that it runs great 

2 Answers

Relevance
  • Anonymous
    4 months ago

    At that mileage rotary Wankel engines often need an overhaul. Particularly so if they have been used for lots of short trips, or if owners have not allowed them to idle for a short time after starting and for a short time after parking. And especially so if they have not been run on MINERAL OIL ONLY.

    The loss of power above 6k RPM is typical of worn or sticking rotor tip seals; usually the latter. Part of the problem with sticking tip seals is that a normal compression test will not always show that unless you can spin the engine to at least 6K RPM during the test. The sticking seals slow down their response rate in maintaining contact with the cylinder walls.

    Fortunately removing the engine is a quick and simple process and the engine itself is designed with regular overhauls in mind so RX/Wankel specialists can turn them around pretty quickly and it’s not a difficult job for experienced amateur mechanics. During an overhaul always replace the oil pump and check that the oil feed pipes to the cylinders and their injectors are not blocked.

    I’m not claiming that this will fix all your problems, but it will eliminate some very obvious causes at that mileage. 

    Join and follow posts by RX/Wankel owners’ groups and you’ll soon learn the correct way to operate and maintain a Wankel rotary. But I stress again: do not use synthetic oil or any synthetic blends on Wankels.

  • Anonymous
    4 months ago

    Replace the plugs.  Clean the MAF sensor.  Check for a clogged cat converter.  Check compression.  Check misfire count with a scanner.  You can see a mechanic with a scope to check the coils and injectors.

Still have questions? Get answers by asking now.