Boot Drive Won't Boot?

So I just finished my custom water loop and after my leak test I plugged everything back in and booted it up. It went to the bios and when i restarted it and went to the boot menu it showed my boot drive which is a 970 pro m.2 nvme 512gb but when I select it to boot it sent me back to the boot select screen after about 2 seconds. Any ideas? 

9 Answers

Relevance
  • 1 month ago

    Check to see if it shows up in BIOS

    Try the drive in another machine

  • 1 month ago

    gergergerger tghh trhrt

  • 1 month ago

    Is there anything on your drive to boot? The boot list only detects bootable devices, not if there is anything bootable on them.

  • 1 month ago

    hmm. sounds like the BIOS/UEFI failed to detect an operating system on your SSD. Disk management software might fix this. Not sure if Win 10 repair will or not ... [I don't use Win 10]

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 1 month ago

    You have a memory leak.

  • Lv 7
    1 month ago

    you have to install an OS on it first.

  • 1 month ago

    Check to see if the drive is securely plugged into the motherboard.

  • 1 month ago

    Try connecting your boot drive to another SATA port and run bios defaults and then click save and see if that helps you

  • 1 month ago

    I'm assuming you already installed your OS, right?

    Make sure your boot drive is set as the first boot device in the boot device priority list.

    If you happen to change the boot type (UEFI/legacy (or BIOS), change it to what it was previously. This can sometimes cause boot issues.

    You can also try a BIOS reset to reset everything to factory settings.

Still have questions? Get answers by asking now.