Laptop (XPS M1530) display not working?

Hi, I have an old Dell XPS M1530, with standard GPU issue of blank display, no boot. I read online that preheating the GPU for a few minutes makes it work for sometime and it had been working for me for a while now. Yesterday after preheating the GPU the PC booted up fine but the display didn't come up until... show more Hi,
I have an old Dell XPS M1530, with standard GPU issue of blank display, no boot. I read online that preheating the GPU for a few minutes makes it work for sometime and it had been working for me for a while now. Yesterday after preheating the GPU the PC booted up fine but the display didn't come up until the windows boot was complete and even then it was at the lowest brightness and nothing i did made it bright. Also after a few minutes the display went out complete.
Looking online, I found a permanent solution for the no boot problem by cleaning the GPU with lighter fluid and reapplying the thermal compound. Even now the system is booting fine but the display problem still exists.

The Nvidia control panel can still detect the GPU so it doesn't seem to be damaged. I need the laptop to work for a few more so i can transfer everything to my desktop. I have also tried to reattach the display flex cable to the mobo.
Please help!
Update: Edit: Thanks guys for prompt replies, but
As described the laptop is old so the warranty is expired. And ram works fine otherwise the laptop wouldn't be able to boot
Remote desktop maybe possible but i just need to get the display running some more time, if possible. So any fix, crude as it may seem, is welcome.
6 answers 6