Empire: Total War Help!?

Hello

I installed Empire: Total War fine, it all installed great and within about 3 hours of playing, my screen started to turn off then my computer reset. When I turned it back on my resolution was to the lowest and I had 4 bit colour like it was an old PC. I was told that it was my graphics card (Nvidia GeForce 8500 gt) so I reinstalled it and updated it to the latest version (7.15.11.8208). But that is still not fully fixed as it still happens every now and then. Now I have another new problem. within about an hour or two of playing, the game shuts off and says "Empire: Total War has stopped Responding" and it always does this. Can anyone please help me? Will I have to reinstall the game or steam? and how can I stop my graphics card doing this?

(PC DETAILS

Windows Vista Service Pack 1

32-bit Operating System

Intel(R) Core(TM)2 Quad CPU @ 2.40Ghz

2.00 GB (RAM)

Nvidia GeForce 8500 GT)

Any help pleaseeeee?

Update:

Hello

I installed Empire: Total War fine, it all installed great and within about 3 hours of playing, my screen started to turn off then my computer reset. When I turned it back on my resolution was to the lowest and I had 4 bit colour like it was an old PC. I was told that it was my graphics card (Nvidia GeForce 8500 gt) so I reinstalled it and updated it to the latest version (7.15.11.8208). But that is still not fully fixed as it still happens every now and then. Now I have another new problem. within about an hour or two of playing, the game shuts off and says "Empire: Total War has stopped Responding" and it always does this. Can anyone please help me? Will I have to reinstall the game or steam? and how can I stop my graphics card doing this?

(PC DETAILS

Windows Vista Service Pack 1

32-bit Operating System

Intel(R) Core(TM)2 Quad CPU @ 2.40Ghz

2.00 GB (RAM)

Nvidia GeForce 8500 GT)

Any help pleaseeeee?

Thanks all, i'll give what you've all said a go. Reinstalling right now

Update 2:

btw, when you said its probably my graphics card thats lacking its performance, its not that. It's working perfectly smooth, its just the game itself having a fit.

5 Answers

Relevance
  • 1 decade ago
    Best answer

    Howdy,

    It's a tough question and one day some one will get it right.

    I put in extra details in the other question but you may not have been notified of the Edit.

    It may not be the Graphics card. It might be the screen resolution or a combination of both.

    At the desktop R-click > Properties Display Settings.

    Set the Screen Resolution to no higher than 1024 x 768

    Click Apply "Keep Settings" > OK.

    Most Questioners say "been playing for 3 hours" - the game may well be a memory hog and the graphics card and Windows virtual memory are working overtime. You will have to save during the game every few minutes. After two hours, quit the game. Shut down the computer for at least 5 minutes before you restart. Gives the Graphics Card time to cool down.

    It may not be Vista compatible and you might have to make it XP compatiblity. Right-Click the Icon you use to start the game. > Properties. Select tab "Compatibility".

    Click and Tick "Run this program for compatibility for"

    The Dropdown has several listings including, possibly, one for Windows XP or Windows 98. Select Windows XP if it is listed otherwise try Windows 98. Apply.OK.

    There are also patches available for Vista Compatibility. Someone else will show you those.

  • 1 decade ago

    get a better video card and some more ram. total war is a very graphic intense game and even on low settings it will be pretty hard to play. vista is a ram eater. if you have ddr ram installed upgrade to ddr2. dont go over 2 gb ram. a 32bit system wont be able to use more then 2 gb anyway.

    get a better video card first yours is dated.

  • 1 decade ago

    First, I'm guessing the installed is corrupted. So try install again. Second, I'm guessing the window vista stability. Try install at Window Xp, If the same problem wouldn't occur. That mean vista not suitable playing the games.Good luck.....

  • 1 decade ago

    Empire is a notoriously buggy game. Try reinstalling the game itself and patch it to the latest version.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 1 decade ago

    http://getinnthis.mitchill.com

    it

    A very informative website you can also get much information in websi

Still have questions? Get answers by asking now.