i cant watch videos on youtube?

i cant watch videos on youtube it say that my javascript is turned off. how do i turn it on?

12 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Microsoft Internet Explorer 5.x, 6.x and 7.x (Windows)

    Select Internet Options from the Tools menu or, for Version 7, from Tools in the upper right portion of your screen.

    Click the Security tab.

    Click Custom level… in Security level for this zone.

    Scroll down to Scripting, near the bottom of the list.

    Under Active scripting, choose Enable.

    Click OK to leave Security Settings. Click OK to leave Internet Options

    Mozilla Firefox:

    1. Go to Tools->Options...

    2. Select the Content tab

    3. Check the box labeled Enable JavaScript

  • 4 years ago

    Hmm, you can try refreshing the page or just try an alternative way to watch videos like Yahoo! Videos or something. Or maybe you can try installing the latest version of Adobe Flash Player and see if it works or not. Hope that helped(:

  • Anonymous
    1 decade ago

    these will help you...

    1. Use Opera browser, it will load faster and smoother, and re-install latest flash.

    get the latest flash player, and install it.. make sure all the browsers are NOT running during installation...

    OR..

    2. It could be due to slow connection or high traffic.

    Try watching it during off peak hours, the video will be smoother.

    Or you could watch it offline... try using 'zillatube' .

    It works well - Just yahoo or google search "zillatube" to get it.

    http://www.dogpile.com/dogpile/ws/results/Web/zill...

    ==========================♥♥♥

  • 1 decade ago

    Internet Explorer for Windows Find the "Internet Options" option in the menubar of your browser (it's probably located in the Tools menu). Click on the "Security" tab. Make sure the "Internet" globe icon is highlighted. Click on the "Custom Level..." button to bring up the security options for your browser. Search through the menu for the "Active scripting" option. Make sure "Enable" is selected. Click the "OK" button. Close this window and click the "Refresh" button of the page requiring Javascript.

    Netscape for Windows Find the "Preferences" option in the menubar of your browser (it's probably located in the Edit menu). Select the "Advanced" arrow in the list on the left side of the window. Make sure that the checkbox next to "Enable JavaScript" is checked. Click the "OK" button. Close this window and click the "Reload" button of the page requiring Javascript.

    Safari for Macintosh Go to and select the "Preferences..." option in the "Safari" menu. Click on the "Security" icon in the top row of preference options. Under the "Web Content:" category, make sure the "Enable JavaScript" box is checked. Close this window and click the "Reload" button of the page requiring Javascript.

    Internet Explorer for Macintosh Find the "Preferences" option in the menubar of your browser (it's probably located in the Edit menu). Select the "Web Content" bullet in the list on the left side of the window. Find the "Active Content" section. Make sure that the checkbox next to "Enable scripting" is checked. Click the "OK" button. Close this window and click the "Refresh" button of the page requiring Javascript.

    Netscape for Macintosh Find the "Preferences" option in the menubar of your browser (it's probably located in the Edit menu). Select the "Advanced" arrow in the list on the left side of the window. Make sure that the checkbox next to "Enable JavaScript" is checked. Click the "OK" button. Close this window and click the "Reload" button of the page requiring Javascript.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • 1 decade ago

    Do you use NoScript with Firefox? If so this would stop it from loading. You would have to allow scripts on youtube.com by right clicking on the page, putting your mouse over NoScripts and clicking allow youtube.com.

  • 1 decade ago

    Try closing the Internet browser and re-open it! If that don't work then try re-installing Java.

    Java Download

    http://www.java.com/en/download/index.jsp

  • 1 decade ago

    Empty your Cache

    All temprary internet files cookies everything,

    Source(s): Experience, i had the same problem.
  • Anonymous
    1 decade ago

    You probably don't have it or someone put up a block on your computer

  • 1 decade ago

    press play

  • 1 decade ago

    TAMMER has the right answer

Still have questions? Get answers by asking now.